SQLite error 11 : database disk image is malformed".

Discussions, questions, comments and suggestions regarding Capture One PRO, Capture One PRO(For Sony), Capture One DB and Capture One Express(For Sony) 8.x.

SQLite error 11 : database disk image is malformed".

Postby Triumph Steve » Wed Apr 29, 2015 2:07 am

Earlier this week, my latest version of Capture One Pro crashed, with the error message "An unrecoverable error was encountered while working with the catalog database, SQLite error 11 : database disk image is malformed".

When I reopened the program, the error message kept showing, the various image folders of the RAW images I had been editing had disappeared, and if I try to import the images again, the program shuts down. I promptly sent a message to Tech Support, which answered with minimal advice about "holding down the Option key and restarting the program. In response I sent the follow-up message the tech Support: "That did not work. I also was advised if I had "saved a copy of my catalog", but I really don't know what that means. As you suggested, if I hold down the "Option" key on my iMac and then try to open Capture One - nothing positive occurs. I still receive the same error message as before. Your recommendation does not help.

Within my iMac's "Finder", if I look at the Favorites/Photo category, I see an icon named "Capture One Catalog.cocatalog" as well as my specific image folders. If I click this icon, Capture One tries to open, but I just receive the same, empty Capture One command screen. What am I supposed to do with this particular icon/place holder in my Finder's Pictures location?

You asked if I had another copy of my catalog. I need to have more specific directions about what you're talking about, as I don't understand what I need to do.

I am really disappointed to have used my favorite Capture One for many years and to have recently paid to upgrade to the Pro level, and then have this unfortunate and destructive event occur. While I do have the original RAW photo images on my computer hard drive, I seem to have lost all of the metadata and other time consuming changes I have made to about 3,000 RAW images I had been editing, and was soon going to convert to JPEGs. It looks like I will have to go back to start all over. However, I am not sure this time that I will use my favorite Capture One Pro software. I cannot trust it now after what has happened, and it looks like this is forcing me to explore a competitor's software.

Also, if I open this now empty Capture One screen and try to "import" images, the program shuts down and closes every time. Capture One Pro is now totally useless for me and won't open, and wont't show me the many RAW images I had previously worked on with adjustments.

In conclusion, I cannot open Capture One with the suggested solution you mentioned. Also, I cannot import new images into it (because the program closes each time). Also, I don't know how to find or salvage my edited RAW images with the "Capture One Catalog.cocatalog" in my Finder/Pictures location.

Question - if I deactivate my copy of Capture One Pro, erase the program off my iMac computer, and then re-download Capture One Pro, will this give me a workable version of Capture One Pro? Will that cause my edits to my 3,000 RAW Olympus images to return, or be erased?

Right now, this disaster looks like it is ending my long-time use of Capture One software, unless I can get your program to open and work for me. Redoing the 3,000 RAW edits is a minor problem, compared to having a non-working Capture One program. I look forward to your advise. Thank you."

I would appreciate anyone's advice about what to do. It is also odd that within my iMac's Finder/Pictures, if I open the date specific image folders for my Leica or Fuji X digital RAW images, I can see the small thumbnail images of both he RAW and JPEG photos. However, if I open the image folders for my Olympus OM-D E-M5II photos, suddenly, the RAW thumbnail images are gone and replaced with a white/grayed out 'page" icon". I called Applecare about that but they have no solution. My iMac is new with ample RAM and hard drive space.
Triumph Steve
Posts: 2
Joined: Sun Jul 22, 2012 6:16 am

Re: SQLite error 11 : database disk image is malformed".

Postby SFA » Wed Apr 29, 2015 2:40 am


Distressing as your problem obviously is you need to know that this is a User to User forum kindly supported by Phase One. It is often visited by some of the Phase team but is not here to provide official support options.

You may find another user posting who has seen similar problems and resolved them but I certainly don't remember this error appearing in any post before. I think the Technical Support team are you best source of help (unless another user happens to be able to help) but I doubt they have extensive experience of the problem either.

Clearly the message sound like a file corruption, presumably for the catalog file, for reasons as yet unknown.

To get up and running again ASAP the usual recommendation wold be to try to reload the catalog database and run a check and repair utility - which is in line with the instructions provided. Obviously for some reason that has not worked this time.

Further investigation about the probable cause (and therefore maybe clues to the solution) might involve attempting to analyse the entries in the log file. I assume you have been asked for that. It may take a while to make sense of it given a rare occurrence.

In the meantime to get you up and running at all, since the program won't open, may well involve a suggestion to re-install the application AND use a backup of the data files (a catalog in this case) if you have one - hence the question.

So do you create a catalog backup? Or maybe have C1 do that for you periodically?

Bear in mind that there are a lot of variables in the technology here and finding the source and cause of the problem may not be easy if things are happening in the depths of the tech. I have no doubt that the Tech team will be seeking to advise you about the best and safest way to deal with the problem so a little patience may be required given the unusual reported error. I know it's worrying and frustrating - I've been on both sides of that fence with different applications over the years. (Never seriously with Capture One though - perhaps I have been lucky but other than the odd glitch here and there - typical for the technology - it has always worked for me so I would fully expect you to be able to rely on it in the future just as much as you could any other software application.

Have you had any changes on your machine recently? OS updates or anything like that? No external drives that are off line or NAS systems attached?

All sorts of things might provide clues about what is happening. It may be worth thinking back to what happened just before the failure became apparent.

Whatever you do don't do anything rash at this stage - unless you know you have a good backup of the system somewhere.


Posts: 6611
Joined: Tue Dec 20, 2011 9:32 pm

Re: SQLite error 11 : database disk image is malformed".

Postby EnderWiggins » Wed Apr 29, 2015 6:50 am

Triumph Steve wrote:I also was advised if I had "saved a copy of my catalog", but I really don't know what that means.

This just means do you have a backup of your catalog somewhere? You should, because on default settings C1 saves a backup every week or so somewhere in the library/application support folder (I'm not on my Mac now and can't give you the exact location). If this was disabled for some reason, do you have Time Machine running on your iMac? This should have backed up the Catalog as well.

Do you get far enough after launching C1 to select the "Verify Catalog" option in the File-Menu of C1 or is it just quitting immediately? That should be the first thing you should try, if it is possible.

I had a damaged catalog database as well some weeks ago. This can fix it.

Folks: Backup, backup and then backup some more. And run the "Verify Catalog" from time to time.
Posts: 135
Joined: Thu Mar 05, 2015 9:11 pm

Re: SQLite error 11 : database disk image is malformed".

Postby Triumph Steve » Thu Apr 30, 2015 2:03 am

Thank you, Grant, and EnderWiggins.

As my iMac is quite new, Time Machine was not yet turned on, and so I cannot recover anything through Time Machine.

I tried to "Verify Catalog", and the result was "Verify Failure" or "Repair Failure". Or, the Verify & Regenerate Preview commands are grayed out and cannot be used. The error message continues to pop up over and over, and the program shuts down over and over.

Within my Finder and Pictures on the iMac, there is a 4.07 GB file called "Capture One catalog.cocatalog". However, I cannot open it, don't know if it is supposed to be opened, I don't know if I'm supposed to do anything with it, and so forth. I cannot "Verify" it, in case that is what I am supposed to do... To bad I can't telephone tech Support and get real time help, as I can with Applecare for my iMac. I sometimes feel that the instructions I receive from Phase One and Tech Support's wording is not basic enough for the lay user who is not a highly experienced computer user. It reminds me of working on my new model Triumph motorcycle and seeing printed instructions that say "remove gas tank". Well, if you don't know how to do that, then the instructions are written over the head of the user. I am a photographer, not an IT expert. Just telling me to "back up my catalog" is not sufficient for me, personally. I need a bit more "step by step" advise. What to do first, second, third, etc.

The good news is that none of the original RAW images are gone. They still reside in the Finder/Pictures location on the computer. However, with Capture One Pro suddenly not opening for me in the normal way, none of the many edits I had applied to about 2,000 images on 3 photo projects I have been working on each night, now appear to have been lost. If I try to create a new Catalog and re-import the RAW images from one of those projects (A series of recent Civil War battle reenactments), the RAW files will import and show the image as normal. But, the edits are now missing. I will now have to go back and redo all of that work, and convert the re-edited RAW images to JPEGs as I go, rather than my earlier preference to edit the entire session, or catalog, and then go back later to convert the best images into JPEGS.

Tech Support basically replied to me today to recommend deactivating the program, then downloading the program again. I guess I will try to do that tonight. Whether or not the program works OK after that reinstatement, and if the edited RAW images appear and (hopefully) show the edits, I don't know what to expect.
Triumph Steve
Posts: 2
Joined: Sun Jul 22, 2012 6:16 am

Re: SQLite error 11 : database disk image is malformed".

Postby meanwhile » Thu Apr 30, 2015 2:29 am

Any chance you've run out of disk space on the drive the catalog is on? I had a similar error a while back, and noticed that the SSD drive was full. Once I cleared some space, it worked again without issues. May not be it, but hopefully.
Posts: 235
Joined: Tue Mar 20, 2012 1:26 am

Re: SQLite error 11 : database disk image is malformed".

Postby SFA » Thu Apr 30, 2015 3:10 am


The cocatalog file (Capture One Catalog) is where all of the catalog information, edits and previews are stored.

The original files can be loaded into the catalog as well (known as "Managed") or may be left outside (Known as "Referenced") From what you have said I would guess you set the catalog up as referenced but in any case it would always be a good idea to save the original files somewhere safe - just in case. At least that allows you to re-start in case of disaster. Make that an off-site backup if your usual location may be prone to natural disasters of any sort.

I would guess that your cocatalog file has some form of problem (based on the message) of unknown origin. I could be almost anything.

Ideally you would want to fix the catalog and then extract the edit information and create a new fresh catalog - and then make sure you keep a backup copy of the working catalog with the most recent edits available.

Having a completely unreadable catalog (or any sort of file for that matter) is unusual these days and might possibly suggest that there may be a need to consider the possibility of a disk failure of some sort. Modern computers tend to watch for such possibilities and map out any area of a disk that might be prone to failure. They will do this from new - nothing is perfect. However it is just possible that an error might have occurred and caused you problem but has subsequently been mapped out so that things appear to be good.

The missing parts of the database may not be missing at all; rather the database might be holding information that is looking for them in the "wrong" place.

If you are going to restart your work I would suggest using a session. And maybe for now start with any images you have no previously worked on so at least you will not be duplicating work when the catalog is, hopefully , recovered in some way.

There are, potentially, ways of edit the database file and identify then fix the problems. However it's not really an non-expert user activity and the size of the file means that sending it off for someone to have a look at is probably not an option either. However that would probably be the thing to do using a web based sharing site that will accept large files.

As a VERY LONG SHOT . have you been asked to try copying the file to create a new copy in a new folder? Then see if that will open. As I said it's a long shot but sometimes a copy activity might just be enough to allow the application to see the file in a different way and make it recoverable. It would be rare though. It does sound like some fundamental issue has affected the file. Really bad luck in that case.

Posts: 6611
Joined: Tue Dec 20, 2011 9:32 pm

Re: SQLite error 11 : database disk image is malformed".

Postby netchaplain » Sun May 01, 2016 9:42 pm

Was there a solution to the problem? I purchased just 2 weeks ago to get away from Lightroom thinking this app was a good solution. Now I have regrets after two crashes that resulted in losing DAYS of edits. I could not recommend this app to anyone who seriously cares about their work. I have lost trust in the company to provide a solution, that appears from all the posts, to have been ongoing for at least 3 years with no fix. Creating another db and starting over IS NOT a solution, it is an atrocious response to the problem.

Now that I have finished venting my frustration--is there a fix that does NOT require starting over? Or am I merely chasing the wind? If not, don't waste your money, find another app!
Posts: 3
Joined: Mon Mar 28, 2016 12:09 pm

Return to Capture One 8.x Software

Who is online

Users browsing this forum: No registered users and 7 guests