Thunderbolt3 - TB2 - Firewire works for Windows 10

General discussion regarding photography practices and Capture One workflow as well as integration with third party applications.
Please DO NOT post to this thread regarding OS specific concerns or questions.
Forum rules
For the sake of being thorough, please remember to note if you are using Mac or Windows.
Hopefully this will keep any confusion to a minimum.

Thunderbolt3 - TB2 - Firewire works for Windows 10

Postby C-M-B » Fri Jun 08, 2018 11:01 am

Alright so after a long battle here's what you have to do to get your PhaseOne back with FireWire to work with new Thunderbolt 3 devices WITHOUT a dock. It's not the most elegant solution but very practical, especially for mobile photographers and those that don't want to spend 300€ for a dock and even more for a power solution.
Now, this won't work with all of them, but those that run on battery will most likely work.

You need:

1. Thunderbolt 3 <-> Thunderbolt 2 Adapter (I use a StarTech)

2. Apple Thunderbolt 2 <-> Firewire 800 Adapter (there's only one kind)

!!!Set your camera back to battery power!!! The adapter chain does not power your device. This is why this only works for backs with battery power capability.

When you connect everything you'll get a message saying "this device may not work properly" because it's an Apple adapter - there used to be a setting in the Thunderbolt Software to turn this off but I couldn't find it anywhere. I simply disabled notifications for the Tunderbolt Software. Headache: gone.
Now open the device manager. You'll see your camera back there but with a notification: the driver signature isn't accepted. No worries though!

I guess this is due to the way everything is connected, it wasn't mean to be run via multiple adapters and so the driver isn't "used" the way it was meant to be and Windows doesn't like that one bit. What we need to do is "force" Windows to accept this driver anyway by disabling the driver signature check.

There are many ways to disable the Windows Driver Signature check and I've tried many.
The easiest solutions are to only temporarily disable it but for me this was unreliable and even though it worked and I was able to tether successfully, after a reboot the drivers weren't accepted any more. However if you want to try it anyway, here's a how-to: https://in.answers.acer.com/app/answers ... nforcement

Because this didn't work for me I went and disabled the Signature Check premanently
via an entry into the Command Prompt/Windows PowerShell.:

Right-click on Start and select "Windows PowerShell (Admin)" or "Command Prompt (Admin)".

Enter the following
Code: Select all
bcdedit.exe /set nointegritychecks on
and press enter. DONE!

If you are on a system with a secure boot (UEFI) you may have to disable secure boot in your BIOS first, otherwise you'll get an error message - then enter the command line again. If you have encryption active you need to deactivate that before you do that and you won't be able to activate it again. Otherwise the Driver Signature Check kicks back in and it won't work again!



Now your driver is going to get accepted and it should work! I've tried it many times, rebooted in between and everything works just fine!




Now for the weird part: I accidentally forgot to put it on battery power - still works. Does Thunderbolt 3 actually deliver enough power via the Adapter to the back?!?!?
C-M-B
 
Posts: 218
Joined: Thu Feb 25, 2010 4:57 pm

Return to Workflow and Common Photography Exploration



Who is online

Users browsing this forum: No registered users and 5 guests