No OpenCL acceleration for X-Trans processing?

Discussions, questions, comments and suggestions regarding Capture One PRO, Capture One DB and Capture One Express 7.x

No OpenCL acceleration for X-Trans processing?

Postby NN635219464465083250UL » Sun Aug 31, 2014 3:21 pm

Greetings,

I just bought a new PC primarily to handle Capture One workloads. Since Phase One stressed the fact that C1 gets a nice boost from the OpenCL acceleration if the sufficient video card is present I made sure that the new PC is equipped with one. Basically it's a top of the line Dell XPS 8700 with AMD Radeon X9 270.

The problem is that it does not seem like C1 applies OpenCL acceleration while processing X-Trans files (99% of the files I process with C1 are X-Trans). There is no difference neither in the screen rendering nor in final processing whatsoever. At the same time when I checked on the same PC how C1 handles standard files (Sony 7R), though I could not see the difference in the screen rendering, the difference in the final processing speed was very noticeable.

If my observations are accurate then it's fairly disappointing. At the very least C1 team should have been clear about the matter so people who process X-Trans files don't invest in the hardware that cannot be utilized. I bought this video card exclusively for C1 acceleration...

Could anyone confirm or correct these observations?

Thanks
NN635219464465083250UL
 
Posts: 4
Joined: Fri Dec 06, 2013 6:07 pm

Re: No OpenCL acceleration for X-Trans processing?

Postby NN635219464465083250UL » Mon Sep 01, 2014 1:29 pm

For anyone who might be interested in this subject.

I contacted Phase One and they confirmed that there is no OpenCL acceleration for X-Trans files processing. I think it is something that should be stated clearly in the official materials related to the C1 OpenCL acceleration. Otherwise it's misleading.
NN635219464465083250UL
 
Posts: 4
Joined: Fri Dec 06, 2013 6:07 pm

Re: No OpenCL acceleration for X-Trans processing?

Postby Adam52 » Tue Sep 02, 2014 12:55 pm

I thought Open-CL just worked with the software regardless of what the file actually is ......

I`d guess there was no OpenGL for Panasonic processing too then as a 16Mp GX7 or G5 file takes FOUR times as long to process as a 24Mp D7100 or 22Mp 1DS Mk3 file - Olympus files from cams with the same sensor process in a fraction of the time - work that out !! ..
Adam52
 
Posts: 42
Joined: Wed Feb 11, 2009 10:00 am

Re: No OpenCL acceleration for X-Trans processing?

Postby Christian Gruner » Tue Sep 02, 2014 2:02 pm

Bear in mind that OpenCL is only used for the image-processing part of the process. Things like unpacking the raw-data also takes time, and the CPU is a lot better at that type of operation than the GPU.

So as observed, the total processing-time will not be proportional to the number of megapixels.
Test-Manager, Capture One, Phase One A/S
Christian Gruner
Crew
Crew
 
Posts: 1828
Joined: Fri Nov 30, 2012 9:48 pm
Location: Copenhagen, Denmark

Re: No OpenCL acceleration for X-Trans processing?

Postby Adam52 » Sun Sep 07, 2014 8:34 pm

Thanks Christian . I can see why X-Trans is a pain but why the serious slowness on Panasonic files ? ..
Adam52
 
Posts: 42
Joined: Wed Feb 11, 2009 10:00 am

Re: No OpenCL acceleration for X-Trans processing?

Postby Christian Gruner » Tue Sep 09, 2014 1:36 pm

There can be a lot of reasons. As I mentioned, unpacking and loading of the raw-file also impacts the total processing time.
Test-Manager, Capture One, Phase One A/S
Christian Gruner
Crew
Crew
 
Posts: 1828
Joined: Fri Nov 30, 2012 9:48 pm
Location: Copenhagen, Denmark

Re: No OpenCL acceleration for X-Trans processing?

Postby Adam52 » Tue Sep 09, 2014 4:07 pm

Hmmm, so why then was version 5 not a problem for this - the more Mp the slower they were, no weirdness like 16Mp Panny files taking 4X longer than 24Mp ones
Adam52
 
Posts: 42
Joined: Wed Feb 11, 2009 10:00 am


Return to Capture One 7.x Software



Who is online

Users browsing this forum: No registered users and 3 guests