Page 1 of 1

IQ4 XF 150 mp won't fire / release the trigger

PostPosted: Mon Dec 10, 2018 11:49 pm
by Patrik51
OK - got my XF and the brand new IQ4 150mp today, and now this evening naturally the first I want to do is make some quick exposures. Everything works like a charm - AF, Live View, menus etc etc. But it won't fire. I can't make a bloody exposure.

I've even read the manual here (!) - turned it on and off, changed the lock code, nibbled around with the vibration delay-thing, changed lenses, AND tried with my old IQ160 back, which worked like a clock. Like taking pictures when pressing the trigger button all the way down. Both cards are in, and tried to fire shots in tethered mode. Nope, didn't work.

Anyone please..? Of course it will be something ridiculous easy, but I'm stuck here...

O - mirror up doesn't work either. But mirror goes up when I press Live View.

Re: IQ4 XF 150 mp won't fire / release the trigger

PostPosted: Tue Dec 11, 2018 12:30 am
by Patrik51
FIXED - Updated firmware on both devices - the XF camera was delivered slightly ahead of the 150mp back.

• Some old fashion breathing, a nice glass of wine, and some slow reading of the release notes again and my fantastic eyes spotted this sentence: "Please be aware that the XF firmware needs to be updated to correspond to the firmware package of the IQ4.You will have to update your firmware, with the file XF-IQ4System1.00.2.fwp or later before using it with the IQ4."

I leave this post for others to learn from, there are better thing to spend a couple of hours on... ;)