Sad reality of moving to MFD

Questions, comments and suggestions regarding Phase One IQ4, IQ3, IQ2 and IQ1 series digital camera backs.

Sad reality of moving to MFD

Postby NNN636463445634415489 » Sat Jun 30, 2018 8:24 am

Well, finally what I have dreaded all the time has happened:
My RZ67ProIID does not communicate with the IQ160 back at all.
I keep powering camera and back off together and in turns, removing and re-attaching the back over and over but alas.

I have tried emergency mode with the X-port->sync cable but back keeps on nagging: "One shot delay is too long, should be shorter than 4 sec" or "One shot delay is too long, should be shorter than 1sec"..
So, perhaps cable worked in theory some long time ago - it's definitely not working in reality!

Except that, I can't see how it is possible to use X-port for triggering AND controlling strobes as well.
So far it managed ONE capture in portrait mode, and as soon as you rotate it landscape it goes dead....going back to portrait doesn't help at all.

I have 3 days left until I travel and have a rather complex project planned....and it looks as I will have to go back to Canon 5D MkIII, which is just abysmal! Though at least it has worked for more than 2 years.. :evil:
NNN636463445634415489
 
Posts: 6
Joined: Wed Nov 15, 2017 1:09 pm

Re: Sad reality of moving to MFD

Postby C-M-B » Sat Jun 30, 2018 11:16 pm

Do you have a spare camera? A backup to see whether it's the back or the camera that's faulty?
C-M-B
 
Posts: 238
Joined: Thu Feb 25, 2010 4:57 pm

Re: Sad reality of moving to MFD

Postby Jon » Fri Jul 13, 2018 7:46 pm

Sorry to hear about this and I hope you found a solution before your trip! Keep in mind that technical issue are better sent to us on our support page so we can help same day.

On the surface it sounds like your adapter plate has failed. This of course can be repaired, but in the short term, the workaround is to use a cable like you mentioned testing. For the cable to work though you have to do one of 2 things:

1. With Shutter Latency set to Normal on the back, there needs to be two signals sent to the back to work. You can either use a Phase Oe wakeup cable and press the wakeup button before shooting, or fire the camera twice within 4 seconds. The first shout will be the wakeup and the second the exposure.

2. Set Shutter Latency to Zero and use the cable - this mode will not require the wakeup signal, but will use significantly more battery power and can cause the back to get too hot. The best way to work in this mode is to turn off the back when you aren't actively shooting.
Kind Regards,
Jon Gilbert
Phase One
Jon
Crew
Crew
 
Posts: 1229
Joined: Fri Jul 06, 2007 6:48 pm
Location: New York, USA


Return to Phase One IQ4, IQ3, IQ2 and IQ1 series camera backs



Who is online

Users browsing this forum: No registered users and 4 guests