IQ260 'bricked' after defaulting to factory firmware

Questions, comments and suggestions regarding Phase One IQ4, IQ3, IQ2 and IQ1 series digital camera backs.

IQ260 'bricked' after defaulting to factory firmware

Postby NN636017976288946646UL » Sat Jun 18, 2016 9:18 am

Hi this problem occured last night as I was trying to restore the firmware back to the factory one. My IQ260 back was removed from my camera body with back plate on.

After the back restarted, the splash screen appeared and thereafter hung there, not budging.

I have tried
- Restarting the back with the power button
- Removed the battery and inserted it in again
- Held the two top silver hard buttons while inserting the battery, counted to four, let go of the buttons and waited, to nothing being different.
- Left the splash screen on until my battery drained out
- Inserted a fresh battery and tried all of the above

My digital back is hereby unuseable, thus 'bricked' and it has been stuck in the splash screen for good.

It is making me very anxious and I really hope someone has experienced and solved this issue before.

I would really appreciate it guys, thanks!

Alex
NN636017976288946646UL
 
Posts: 2
Joined: Fri Jun 17, 2016 11:00 pm

Re: IQ260 'bricked' after defaulting to factory firmware

Postby brianmerwin » Wed Jun 29, 2016 4:29 pm

Hi Alex - There could be a variety of things going on here. The best course of action is to contact your dealer so they can review and escalate the issue appropriately.
brianmerwin
Certified Professional
Certified Professional
 
Posts: 243
Joined: Fri Nov 23, 2012 7:59 pm
Location: Atlanta, GA


Return to Phase One IQ4, IQ3, IQ2 and IQ1 series camera backs



Who is online

Users browsing this forum: No registered users and 1 guest