reoccuring problem: fungus spots on inside of IR filter

Question regarding:Phase One H25, H20, H101, H10, H5, LightPhase, PowerPhase FX / FX +, PowerPhase, PhotoPhase and StudioKit.
Leaf Valeo, C-Most, Cantare, Volare and DCB.

reoccuring problem: fungus spots on inside of IR filter

Postby tom2 » Thu May 01, 2008 7:00 pm

I've noticed fungus spots on the inside of one of my IR filters, and have talked to a few other owners who have had the same problem. And I saw another post from someone having the same problem. Is this a problem PhaseOne has been addressing and helping original owners with since it seems to be reoccurring?
tom2
 
Posts: 9
Joined: Wed Mar 30, 2005 2:01 pm
Location: Cinti, Oh

Postby filmless » Mon May 05, 2008 3:18 pm

Hello,

Since it has been several days since you posted I am assuming you have gotten your answer, but my experience has been this:

Only the H20 had a true fungus problem that originated from the IR chemical coating. Phase One recognized the problem early on and switched to a different IR coating. If you owned one of the original items and developed a fungus problem Phase repaired the DB for free by switching out the IR glass (I don't know what the current policy is, please check with Phase One).

If you have a different DB (other than an H20) or have a reoccurring problem then it sounds like you may have a different issue. These backs do not develop fungus if everything is proper. I would recommend starting a case with Phase or at least talk to your dealer.

I shoot here in Atlanta Ga, one of the most humid places you can find in the summer time, none of our DB's have a problem... so something is wrong.

good luck,

Tim
Tim Palmer
Technical Services
Capture Integration
www.captureintegration.com
tim@captureintegration.com
filmless
 
Posts: 9
Joined: Tue Nov 15, 2005 7:35 pm
Location: Atlanta Ga USA

Postby tom2 » Tue May 06, 2008 1:07 pm

Tim, thanks for the info. No I got no replies or answers, but my problem is that there are a hundred or so spots that have developed behind the IR filter, same as another owner had happen here in my town. The affected DB of mine is a LightPhase, my H10 is fine. My dealer priced a replacement by Phase at about $1400 & Phase won't sell me the replacement part without Phase doing the replacement, though the back is out of warranty and though I have access to a clean room. So I guess I'm on my own, though the back was mot misused/abused or stored anywhere peculiar to cause this.
tom2
 
Posts: 9
Joined: Wed Mar 30, 2005 2:01 pm
Location: Cinti, Oh


Return to Phase One and Leaf Legacy one-shot and scan camera back



Who is online

Users browsing this forum: No registered users and 2 guests