Schneider 80mm LS lens short-circuit during lens-change

Discussions regarding Phase One 645 DF / DF+ and Mamiya 645 DF / DF+
Also lens discussion for Phase One and Schneider lenses.

Schneider 80mm LS lens short-circuit during lens-change

Postby NN634719358590218983UL » Sat Jul 19, 2014 1:05 am

I just experienced spectacular lens failure during lens change. And I see no documentation warning of this issue.

I've changed lenses on countless cameras of different makes. Never has it occurred to me that one has to make sure the camera is turned off to do so (old strobe packs like Norman had to be turned off before unplugging heads, but lenses?)

I took one lens off and mounted the 80mm LS lens on my DF body. While doing so I noticed a bright spark at the bottom of the lens. I finished mounting it, and the LS mechanism no longer works. When exposing with the lens in LS mode, the exposure is about 1s+ and totally overexposed. The lens still focuses (which is mechanical). Also the aperture ring still works if shot in FS mode. Body works with all other lenses. And if I change custom setting to force camera into FS mode the 80mm lens still works as expected. Power cycled and removed battery to see if it would reset, no luck.

My assumption is that the contacts of the lens must have touched the body in an unfortunate configuration, created a short circuit that fried the LS circuit board. That seems like a serious design flaw of the lens.

I have since checked the manual of the body and the PhaseOne website tutorials. No mentions of having to turn off the camera prior to lens change. Asked a few fellow PhaseOne shooters, they never turn their cameras off for lens change.

Has this happened to anyone else? Do any of you turn your cameras off? You may want to do so now....

Jan
NYC
NN634719358590218983UL
 
Posts: 1
Joined: Sun May 06, 2012 10:17 pm

Re: Schneider 80mm LS lens short-circuit during lens-change

Postby FredBGG » Sat Jul 19, 2014 7:04 pm

For you to notice the electric discharge the distance between the contacts from body to lens would be too far for it to be a low voltage discharge. It was most likely a static electricity discharge.

Two things increase the risk of static electricity discharge.

Too much rubber on the body so that the body and lens are not equivalently "grounded by the body"

Having the body grounded by either a sync cable or tripod while the lens is not grounded.

However these days electronics should be more resistant to static electricity.
FredBGG
 
Posts: 218
Joined: Wed Feb 24, 2010 8:11 pm


Return to Phase One 645DF and DF+ / Mamiya 645DF and DF+



Who is online

Users browsing this forum: No registered users and 4 guests