Phase One 645DF shutter release issue

Discussions regarding Phase One 645 DF / DF+ and Mamiya 645 DF / DF+
Also lens discussion for Phase One and Schneider lenses.

Phase One 645DF shutter release issue

Postby sledder » Mon Oct 29, 2012 7:37 pm

I have been working with a photographer regularly and for the last month or so, I have been witnessing a really odd reoccurring issue when pressing the shutter release button on the body. He is using the Phase One 645DF with a P40 back

Every so often when shooting, pressing the shutter release does nothing. It simple doesn't respond. Sometimes it may come back to life, other times after a few presses it sounds like the shutter is being released but doesn't capture anything, either on the back or capture one.

I have tried all sorts of things to solve it, I cleaned all the contacts + restarting and removing batteries etc.

I am starting to think that this may be a hardware problem, but thought I would check on here to see if anybody has come across this problem as wel.

Any information would be greatly appreciated.
Certified Professional
Certified Professional
Posts: 12
Joined: Fri Nov 11, 2011 2:48 pm
Location: San Francisco

Re: Phase One 645DF shutter release issue

Postby Jim_DK » Wed Oct 31, 2012 9:57 am

You do not mention firmware versions for either back or camera. I think regardless, this would be best handled either in a support case or in a dialog with the dealer.
Posts: 680
Joined: Thu Dec 03, 2009 10:00 pm

Re: Phase One 645DF shutter release issue

Postby Gareth » Wed Oct 31, 2012 9:47 pm

Had this happen with mine where the shutter button doesn't respond then it suddenly fires and I usually get a really over exposed frame.

What seem to have solved it for me was stopping the camera going to sleep so quickly. From memory I think default the camera powers down after 15 seconds which is way too short a time between captures IMO. I have set mine to 60 second and not had the issue since. I think the camera and back get out of sync during power down and need a bit of time to connect together again causing these strange behaviours.
Posts: 127
Joined: Thu Oct 02, 2008 6:37 pm

Return to Phase One 645DF and DF+ / Mamiya 645DF and DF+

Who is online

Users browsing this forum: No registered users and 3 guests