Mamiya 645DF+ with Leaf Aptus II 8 - Mirror Locked Up

Discussions regarding Phase One 645 DF / DF+ and Mamiya 645 DF / DF+
Also lens discussion for Phase One and Schneider lenses.

Mamiya 645DF+ with Leaf Aptus II 8 - Mirror Locked Up

Postby srtemple13 » Wed May 22, 2019 7:19 pm

Hello everyone,

I'm really hoping someone can help me out. I just purchased a Mamiya 645DF+ from KEH to pair with a Leaf Aptus II 8 back that I've had for years. Up until now, the Leaf back has been used on a Cambo Ultima platform with no problems whatsoever. I bought the Mamiya so I could also shoot handheld with the Leaf back.

Here are the problems I'm dealing with:
1. The mirror on the Mamiya 645DF+ is in the up position and will not come down no matter what I do.

2. This may or may not be a related problem. Initially, the battery was too drained to power the camera body so I charged it overnight. Even though the battery was on the charger overnight, the LED on the Mamiya charger was still red. After charging, the camera powered up fine and the battery level indicator on the body read as full.

3. The Leaf back does not recognize the Mamiya body. On the main menu screen of the Leaf back, the camera button on the left of the screen is greyed out. All the other buttons work fine.

Equipment specs:
Mamiya 645DF+ Camera Body
Firmware version: 2.27

Mamiya / Schneider - Kreuznach 80mm f/2.8 Lens
Firmware version: 2.17

Leaf Aptus II 8 Digital Back
Firmware version: 5.048

Thanks!
Steve
srtemple13
 
Posts: 7
Joined: Sun Oct 23, 2011 2:19 am

Re: Mamiya 645DF+ with Leaf Aptus II 8 - Mirror Locked Up

Postby srtemple13 » Wed May 29, 2019 12:41 am

**PROBLEM RESOLVED**

Here is what I did to fix the problem and get the camera working.

1. Updated C1 - I updated Capture One from version 12.0.2 to 12.0.3.

2. New camera battery - I purchased a AA battery adapter for the 645DF+ body. Even though the battery read as full, it was toast. Powered by the original battery and after updating Capture One to 12.0.3, the camera fired up and the mirror dropped. I focused and took one frame, this was enough to completely kill the battery. After installing the AA batts everything worked fine.

Between these two changes the camera us now functioning properly when tethered to a Mac.
srtemple13
 
Posts: 7
Joined: Sun Oct 23, 2011 2:19 am

Re: Mamiya 645DF+ with Leaf Aptus II 8 - Mirror Locked Up

Postby NNN636987916885004610 » Mon Jul 15, 2019 11:50 am

srtemple13 wrote:**PROBLEM RESOLVED**

Here is what I did to fix the problem and get the camera working.

1. Updated C1 - I updated Capture One from version 12.0.2 to 12.0.3.

2. New camera battery - I purchased a AA battery adapter for the 645DF+ body. Even though the battery read as full, it was toast. Powered by the original battery and after updating Capture One to 12.0.3, the camera fired up and the mirror dropped. I focused and took one frame, this was enough to completely kill the battery. After installing the AA batts everything worked fine.

Between these two changes the camera us now functioning properly when tethered to a Mac.

Thanks for sharing this solution , i also facing a same problem. Thanks a lot for sharing with us.
NNN636987916885004610
 
Posts: 1
Joined: Mon Jul 15, 2019 1:48 pm


Return to Phase One 645DF and DF+ / Mamiya 645DF and DF+



Who is online

Users browsing this forum: No registered users and 2 guests