Leaf Aptus II-6 on Hasselblad 203FE

Question regarding:
Phase One H25, H20, H101, H10, H5, LightPhase, PowerPhase FX / FX +, PowerPhase, PhotoPhase and StudioKit.
Leaf Aptus-II, Aptus S, Aptus, Valeo, C-Most, Cantare, Volare and DCB.

Leaf Aptus II-6 on Hasselblad 203FE

Postby Rendy » Wed Sep 09, 2015 2:57 am

Can I physically mount the Leaf Aptus ii-6 v-mount on Hasselblad 203fe? I know Hasselblad 203FE is not supported on Leaf Aptus II-6, but I think it can be used with 203fe setup in "C" mode with a CF/CFi.CFE lens. Am I correct on this? Thanks!
Rendy
 
Posts: 2
Joined: Fri Feb 26, 2010 8:11 pm

Re: Leaf Aptus II-6 on Hasselblad 203FE

Postby Paul_Steunebrink » Mon Sep 14, 2015 11:43 am

I would expect it would work in C mode as mentioned. To be sure, contact Phase One support.
User avatar
Paul_Steunebrink
Certified Professional
Certified Professional
 
Posts: 9488
Joined: Tue Feb 06, 2007 8:49 pm
Location: The Netherlands

Re: Leaf Aptus II-6 on Hasselblad 203FE

Postby Rendy » Tue Sep 15, 2015 2:15 am

Thanks for the quick response!

I recently purchased this digital back and having hard time physically mounting it on my 203fe. It can't consistently stay in latch. If I push the back against the body harder, I can mount it 1 out of 20 times. I am wondering if this is 203FE issue? I thought the Hasselblad v-mount is same for both 500- and 200-series.

Once the digital back is mounted, I can confirm that the back works in c-mode with 203FE with camera setting in "large format". It also work in "Hasselblad 500 series" but not as consistent as in "large format" setting.

thanks!
Rendy
 
Posts: 2
Joined: Fri Feb 26, 2010 8:11 pm


Return to Phase One and Leaf Legacy one-shot and scan camera back



Who is online

Users browsing this forum: No registered users and 0 guests