Phase P30 back and Hasselblad 500c/m images not in focus

Questions, comments and suggestions regarding Phase One P+ series and P series digital camera backs.

Phase P30 back and Hasselblad 500c/m images not in focus

Postby NNN636227062053616100 » Fri Nov 10, 2017 6:42 pm

Greetings!

Last year I picked up a used P30 to use with my Hasselblad 500CM.

As I've been using it over the last year, 99% of my images are totally out of focus.

I've replaced the viewing screen with a split-level focusing screen, and I also use a 90 degree prism with an adjustable diopter. Images that look in focus in my eyepiece/focusing screen are very out of focus when I open the files up on the computer.

Someone suggested adjusting the shims on under the viewing screen on the 500cm, but I don't how how to do that. Others have suggested that the camera needs to be calibrated with the back, but I don't know how to do that either.

Do you have any advice on how I can get this back to work properly with the camera? I don't know of any local places in my area (New Hampshire) that specifically deal with PhaseOne products.

Thanks in advance.

Cheers,
Sid
NNN636227062053616100
 
Posts: 1
Joined: Tue Feb 14, 2017 10:56 pm

Re: Phase P30 back and Hasselblad 500c/m images not in focus

Postby PhaseoneUser55657 » Sat Nov 11, 2017 12:57 am

Just a few things I would check first.

Use one of those focus adjust meant tools. (i.e the ones with ruler on an angle and a target to focus agains.)
This will tell you how far out of focus the system is.

I have never heard of putting shims under the glass screen, that is something new to me. If you have a mask that shows what the sensor is seeing, you may want to remove that.

I believe that you have to send in the camera and back to get the back adjusted to the system.

Robert
PhaseoneUser55657
 
Posts: 221
Joined: Mon Aug 06, 2012 2:19 pm


Return to Phase One P+ and P series camera backs



Who is online

Users browsing this forum: No registered users and 2 guests