invert mask filling in

Discussions, questions, comments and suggestions regarding Capture One PRO, Capture One PRO For Sony / Fujifilm, Capture One DB and Capture One Express For Sony / For Fujifilm 12.x for Mac

invert mask filling in

Postby NNN636910270657923234 » Thu May 02, 2019 3:05 pm

Hello, I am having issues with the invert mask command. I created a mask of a bird, layer 1, the mask looks pretty good. I then created another layer and copied the mask from layer 1 which I want to invert and use to blur the background a bit but when I invert the mask it just fills the whole screen, bird and background, so I end up with 100% mask coverage. Any thoughts on what I may be doing wrong? Cap 12.0.3 for Sony/Mac.

Searched the forum and went through the manual but can't find an answer.

Really liking this program so far. Detail and quality are much better than others I have used. Thanks!
Ric
NNN636910270657923234
 
Posts: 4
Joined: Tue Apr 16, 2019 4:57 pm

Re: invert mask filling in

Postby SFA » Thu May 02, 2019 3:55 pm

Firstly are you absolutely sure that you are copying the mask from the correct layer?

Secondly does the mask you are copying have any element of Luminosity Range as the basis for the mask at some point in its creation? I don't know whether that might have any significance but it would be useful to know.


Grant
SFA
 
Posts: 6818
Joined: Tue Dec 20, 2011 9:32 pm

Re: invert mask filling in

Postby NNN636910270657923234 » Thu May 02, 2019 4:09 pm

Hi Grant,

#1 - Yes. The mask is set to visible so when I copy it, I clearly see that it is the same mask.

#2 - When I created it, I used the brush and auto-mask option, filling the mask when done. I did not use any luminosity feature at all.

BTW - creating a mask with the luma tool is pretty slick! I used it on a couple of other photos.
NNN636910270657923234
 
Posts: 4
Joined: Tue Apr 16, 2019 4:57 pm

Re: invert mask filling in

Postby SFA » Thu May 02, 2019 5:14 pm

When you drew the mask on layer one what were the opacity and flow settings?

If the mask form which you are copying was not drawn with 100% opacity the inverted mask will not have the balance of the opacity . I offer than as an example that might throw some light on what you are seeing.

The Opacity setting is for the maximum opacity possible for that mask. The Flow control defines how much of that potential opacity is applied for each contiguous brush stroke.

I'm just wondering if this is a factor for what you are seeing.


Grant
SFA
 
Posts: 6818
Joined: Tue Dec 20, 2011 9:32 pm

Re: invert mask filling in

Postby NNN636910270657923234 » Thu May 02, 2019 6:32 pm

The opacity was set at 100 and the flow was 62. I brushed around the inside of the bird (an inline instead of an outline, if you will) and then used the fill mask command. Still not confident in how some of these settings work but maybe I had a leak in the outline somewhere or rather an imperfect border?

I will play with this a bit more changing the flow maybe. This doesn't seem to be quite as easy as magic lasso but it is an intricate mask so luma and color masks aren't working for me.
NNN636910270657923234
 
Posts: 4
Joined: Tue Apr 16, 2019 4:57 pm

Re: invert mask filling in

Postby Eric Nepean » Thu May 02, 2019 7:34 pm

Try rasterizing the mask before you copy it.

Right click on the mask layer, and select rasterize.
Eric Nepean
 
Posts: 573
Joined: Sat Oct 25, 2014 8:02 am
Location: Ottawa

Re: invert mask filling in

Postby NNN636910270657923234 » Thu May 02, 2019 9:22 pm

I tried rasterizing and it didn't change the situation. I clearly did something strange when I created the mask because if I just scrap it and start over, everything seems to work as intended. I did a much simplier test on the same file and the inversion was fine. I was hoping to salvage the mask because it took so long to create but I will just start over. If I happen to hit on what caused it, I will post here so others may learn from my error.

Thanks for the replies!
Ric
NNN636910270657923234
 
Posts: 4
Joined: Tue Apr 16, 2019 4:57 pm


Return to Capture One 12.x Software for Mac



Who is online

Users browsing this forum: No registered users and 1 guest