Page 1 of 1

P30 back memory card crashed and is not showing pictures

PostPosted: Mon May 07, 2018 10:07 am
by NNN636577747837350708
Hi everyone,
I am new to this forum so any help will be much appreciated.
I was using my P30 last night outside with long exposures (30 seconds max) on a Hasselblad 503, my memory card was a 8gb and after being nearly full with 20 or so pictures left it showd that it was full.
To my surprise when I went to play back it wasn’t showing any pictures at all, connecting it to my imac to download the pictures it didn’t even come up when plugged in. I tried on a PC and it was saying that the card needed formatting before use. This is a SD card with a CF adapter but a week ago I had the same message card full on a 1gb CF card, which after re formatting worked perfectly after.
Is anything I am doing wrong, does a card need reformatting before every use?
Thank you in advance for any responses and feel free to ask any questions on details I have missed to give.

Re: P30 back memory card crashed and is not showing pictures

PostPosted: Mon May 07, 2018 1:55 pm
by C-M-B
SD to CF card adapters simply aren't reliable enough, errors when reading the cards or writing to the cards as well as complete or partial data loss are very likely to happen.

I'd suggest you but CF cards and a CF card reader and use that instead.

Re: P30 back memory card crashed and is not showing pictures

PostPosted: Mon May 07, 2018 2:35 pm
by NNN636577747837350708
Thank you for your reply, it did it last week on a 1gb Sandisk CF card but I didn’t think much of it.
I am just worried that it’s something the db is causing, has it been heard this before?
Will use CF cards from now on and see if it happens again.