Page 1 of 1

Phase one P30+ back does not turn on, solid red LED

PostPosted: Mon Mar 19, 2018 7:26 am
by srmenon
Hi All,

I have experienced this issues on two occasions now with my back that I have taken approx 150 shots with. The when the battery is inserted, the back briefly flashed both the red and green LEDs, the green LED goes off and the red LED stays solid. If you open the cover for the CF card, the LED below the card slot is also solid red. This happens irrespective of whether there is a card in the slot or not. The first time, removing the battery and replacing it after a while helped, I am having no such luck this time.

I have read the manual and scanned the internet but it seems like a unique issue. Any leads or fixes?

Regards
S

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Mon Mar 19, 2018 2:23 pm
by Ulf
Hi

This means it has lost its firmware.
Contact us in support and we'll try to help you out
http://support.phaseone.com/

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Wed Mar 21, 2018 9:20 pm
by srmenon
Hi Ulf,

Proceeded as you suggested. Just stopping by to say thanks.

Regards
S

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Sun Nov 17, 2019 2:45 am
by NNN636452453518237846
Hello
I acquired recently a "new"P30+ in one of the main shop specialised in medium format and pro camera in Paris. I thought it was a bargain since the shutter count is only 760 count !

I did a few shots with it No problem.

But when I wanted to try it in production (meaning pro shooting), I mounted it in my DF+. The DF+ told me that the card format was not correct. I am using SanDisk Extreme CF card 16GB at 60 MS/s. I never had such issue before with my previous P30+ which I sold and my IQ140. I formatted the card but when I tried to take a photo It locked the DF+ meaning that the shutter at the back of the DF+. The DF+ is supposed to have the latest firmware.

So I formatted the CF card and rolled back to my my AFDIII. I took another card of the same type. Formated it on the P30+ , I did a reset to defaults of the P30+ . Then I take a photo with the AFDIII , the shutter on the AFDIII works well. I see a flashing green light on the P30+ then it turns red and the screen turns black with a red light remaining. It is locked and I have no solution than to take off the battery. It seems that it tries to write on the card but unsuccessfully.

Is it samewise a question of Firmware on the P30+ ? How do I unlock the DF (I mean the shutter on the back is locked).

Thanks a lot for help. This P30+ is important to me for my Phase One AFIII and also because I intend to use it for my Large Format project...

Have a good day !

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Sat Nov 23, 2019 8:29 pm
by NNN636452453518237846
hello

no help ?

I downloaded the firmware updater for MacOS, I connect my P30+ through firewire port ( I have to use a firewire 400->800 cable) to my iMac and the software does not see the P30+ ... :evil:

Helpless... :(

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Mon Nov 25, 2019 8:41 am
by Ulf
Hi

This is a user to user forum.
If you need help right away then contact your local Phase One partner or us in support

http://support.phaseone.com/

Re: Phase one P30+ back does not turn on, solid red LED

PostPosted: Mon Nov 25, 2019 2:43 pm
by NNN636452453518237846
thanks Ulf for the useful comment ! :shock:

what is a "user to user" forum ? if we can't help each other :lol:

Indeed the support of Phase One answered me and I am going to post the solution so it can help others in my case and to submit useless cases to Phase One.

It was a three step solution:

1) download and install the firmware updater (I advise users to do it before any os migration)
2) download the firmwares and updated them. be careful a P30+ is firewire 400 so I needed an authentic firewire 400-800 cable.
3) Images were not good on my Schneider K. so I had to set up latency to "long" to "short".

Well it was done. no need to pay a visit to my phase one reseller... And I hope that it can help somebody else using a P+ on a recent camera. Some tuning are required.

A big thanks to the kind support tech team of Phase One.