Swithing on the P25 with Mamiya 645 afd

Questions, comments and suggestions regarding Phase One P+ series and P series digital camera backs.

Swithing on the P25 with Mamiya 645 afd

Postby Andrew4 » Thu Sep 22, 2005 6:08 pm

1. After the back has been switched off for a period of time it won't switch on with the on/off button I can only switch on by taking the battery out and then putting it back in--Please can you help or is it a problem with the back?
Andrew4
 
Posts: 4
Joined: Thu Sep 22, 2005 6:02 pm
Location: North East England

Postby Ulf » Mon Sep 26, 2005 5:42 pm

Check firmware version, should be 3.3.4, if not firmware uploader can be downloaded from www.phaseone.com.
Older firmwares does not have support for trigger capture from computer which this one does.

If problem persist after firmware upgrade, contact your dealer.
Ulf
Crew
Crew
 
Posts: 3444
Joined: Wed Oct 06, 2004 1:52 pm
Location: Copenhagen Denmark

Postby James Walker » Tue Oct 04, 2005 10:31 pm

I have a similar problem with my P20 back on a Mamiya RB67. After the back has been switched off for a while it takes three presses of the power button to start the back. The sequence is as follows:

1st press: 2 lights flash briefly then go out and nothing happens.
2nd press: No lights flash and no power.
3rd press: Both lights flash briefly, green light stays on longer and back powers up.

The odd thing is if I remove and reinsert the battery, or connect the Firewire cable the back powers up first time without fail.

Firmware is latest version (3.3.4).
James Walker
 
Posts: 1
Joined: Tue Oct 04, 2005 10:06 pm
Location: North West England


Return to Phase One P+ and P series camera backs



Who is online

Users browsing this forum: No registered users and 2 guests