P25 with H1 Body

Questions, comments and suggestions regarding Phase One P+ series and P series digital camera backs.

P25 with H1 Body

Postby fwlun » Thu Nov 18, 2004 4:18 pm

Anyone knows how to connect studio flash to P25 back on H1 body? The User Manual came with the back does not have a connection with H1 body and I tried with the connection cable that came with the back but it did not work.
fwlun
 
Posts: 15
Joined: Wed Nov 03, 2004 5:18 pm

Postby damienlovegrove » Thu Nov 18, 2004 6:23 pm

Plug the flash into the sync socket on the side of the camera not the P25 back. The socket is under the black rubber plug on the left of the camera.

Damien.
User avatar
damienlovegrove
DB Owner
 
Posts: 215
Joined: Tue Nov 02, 2004 7:58 pm
Location: Bristol UK

Postby Michael Grøn » Thu Nov 18, 2004 10:07 pm

Now you have got freedom of movement with the P25, you surely don't want to drag around a sync cable.

Why not opt for a flash trigger unit such as e.g. the low-cost Multiblitz which connects to the sync socket on the camera.

Regards Michael
Michael Grøn
 
Posts: 46
Joined: Tue Nov 02, 2004 10:56 pm
Location: Aarhus, Denmark

Postby erikhoffman » Fri Nov 19, 2004 1:14 pm

sync cable whats that
use a bowen pulsar on the hot shoe and leave the little sync socket alone

Erik
Mamiya P45,Nikon D2x,Kodak SLRn,DualX pc,Power Book G4
User avatar
erikhoffman
 
Posts: 68
Joined: Sun Nov 07, 2004 12:20 am
Location: london

Re:

Postby fwlun » Fri Nov 19, 2004 3:25 pm

damienlovegrove wrote:Plug the flash into the sync socket on the side of the camera not the P25 back. The socket is under the black rubber plug on the left of the camera.

Damien.


Thanks for your reply. It's so simple. For some reason when I first connected the sync cable to the H1 and my studio flash did not go off. I must have blocked the infrared from reaching the studio flash unit. So I was looking for the user manual to see if I did something wrong. After your suggestion and it worked. It must be magic. Thanks anyway.
fwlun
 
Posts: 15
Joined: Wed Nov 03, 2004 5:18 pm

Re:

Postby fwlun » Fri Nov 19, 2004 4:31 pm

erikhoffman wrote:sync cable whats that
use a bowen pulsar on the hot shoe and leave the little sync socket alone

Erik

Thanks for your suggestion. I've seen them around but I did not know what it does.

BTW. Do you have problem with H1 will not shut off if you turned off the P25 first. I must turn off H1 first before I turn off P25 back. Is it the problem of H1 or P25? Anyone knows?
fwlun
 
Posts: 15
Joined: Wed Nov 03, 2004 5:18 pm

Postby damienlovegrove » Sat Nov 20, 2004 1:45 pm

I also have a problem trying to switch the H1 off. I haven't associated the issue with the P25. I'm sure a camera or back firmware review will sort it. I have to press the off button for about 2 seconds and wait a further 2 seconds before the H1 logo appears. Then a further press switches the camera off sometimes.
User avatar
damienlovegrove
DB Owner
 
Posts: 215
Joined: Tue Nov 02, 2004 7:58 pm
Location: Bristol UK


Return to Phase One P+ and P series camera backs



Who is online

Users browsing this forum: No registered users and 34 guests