New Camera with some issues

Discussions regarding Phase One 645 AF and Mamiya 645AFDIII Camera

New Camera with some issues

Postby Dennis25 » Tue Jun 28, 2011 12:31 am

Has anyone run into any of these issues? I purchased a new Phase One 645 Camera with a P40+ back.

- when the camera falls asleep, it takes four pushes of the shutter button to wake it up

- after the camera wakes, sometimes on the first exposure, the image is three stops too bright.

- sometimes I will get a static-filled screen instead of the image I shot.

- when tethered, I have to power off the camera when switching capture folders.

- the rechargeable battery is very difficult to remove from the vertical grip.

Thank you for any input!
Dennis25
 
Posts: 20
Joined: Wed Jan 21, 2009 3:39 pm

Re: New Camera with some issues

Postby HAMANI » Tue Jun 28, 2011 1:28 pm

Yes Dennis you have just pointed out some of the most ennoying problems with Phase One 645 Camera, though many also exist with Capture One 6.2.1 (for example), when used in our studio with a P65+ back (and other backs).
I am hoping for a quick firmware update because the "3 stops too bright" problem - for instance, but not the only one - is very disturbing if you don't permanently have an eye on the screen you might think you got the picture as you thought... I do not understand why it takes so long to fix such a general problem. So just so you know, you're not the only one experiencing problems with this very expensive equipment.
Cheers.
HAMANI
 
Posts: 4
Joined: Thu Nov 20, 2008 6:18 pm

Re: New Camera with some issues

Postby Dennis25 » Wed Jun 29, 2011 2:10 pm

Thanks Hamani. I appreciate you taking the time to write. I'll keep an eye out for improvements, as I'm sure you will too.
Best.
Dennis25
 
Posts: 20
Joined: Wed Jan 21, 2009 3:39 pm


Return to Phase One 645AF and Mamiya 645AFDIII



Who is online

Users browsing this forum: No registered users and 1 guest

cron