Major P1 645 AF Problem

Discussions regarding Phase One 645 AF and Mamiya 645AFDIII Camera

Major P1 645 AF Problem

Postby Johnnykurtz » Sat Jun 18, 2011 7:14 pm

Hello all,

I am shooting in Dresden Germany now and have a huge problem that hope some wizard like person here on P1 can answer.

I traveled from Utah (home) with my P1 645 AF and P40+ back. After shooting around the city and Elbe valley for a few day under very easy conditions, my shutter has stuck closed.

I have tried removing and replacing the back, batteries (both back and camera, various lenses, tried me Mamiya remote (the long one) cleaned all contacts and even drank a fine glass of Montepulciano

Noting is releasing the shutter. I hear a slight motor sound when I depress the shutter button fully and the AF works great. The mirror will not go up as well, but this should be normal as it syncs with the shutter.

Please, please, any insight will be greatly appreciated. One good thing is I am closer Denmark now, but really do not want to send it off.
__________________
User avatar
Johnnykurtz
 
Posts: 34
Joined: Mon Mar 02, 2009 11:57 pm
Location: Salt Lake City

Re: Major P1 645 AF Problem

Postby Aztecaphoto » Sat Jun 18, 2011 9:23 pm

Hi:
When you remove the back, the shutter opens? If not... it won´t be expensive to repair.
Try to inspect your last frames, as they can show that a blade was doing something funny. It happened to me but with a Mamiya 645AFD.

Regards
Aztecaphoto
Certified Professional
Certified Professional
 
Posts: 66
Joined: Mon Oct 13, 2008 7:21 am
Location: México City


Return to Phase One 645AF and Mamiya 645AFDIII



Who is online

Users browsing this forum: No registered users and 1 guest