Page 1 of 1

New Canon SDK in 6.4.5

PostPosted: Tue Jan 15, 2013 8:40 am
by GoranLjubuncic
Now that 7.0.2 officially supports 10.8 it's time to incorporate the new Canon SDK in COP 6 because basically it's a major bug and the workaround is only a workaround. I hope the Phase One won't leave the 6 users out of the loop.

Goran

Re: New Canon SDK in 6.4.5

PostPosted: Tue Jan 15, 2013 11:13 am
by Drew
GoranLjubuncic wrote:... because basically it's a major bug and the workaround is only a workaround.


A "Bug" would imply that this is a programing mistake. This is, however, a limitation caused by compatibility between Canon's software and Apple's Operating System, Capture One software is simply caught in the middle.

As integration from our end would do the exact same thing as the available workaround, it is still suggested that the workaround be used by those users that would like to remain with Capture One 6 Pro on the 10.7.5 / 10.8.x OS'.

viewtopic.php?f=40&t=12926

Re: New Canon SDK in 6.4.5

PostPosted: Thu Jan 17, 2013 8:58 pm
by R_Weber
For power users the workaround is fine but for a lot of my clients this is an intimidating process. I think it's sort of messed up that 6 users have to crack open two different softwares and combine parts to get their $300 software working with their camera. I understand that this is a limitation of Canon's software with OS X but it's Capture One users that suffer and therefore, in my mind, a Capture One problem. When I have to give this bad news to clients (even with an explanation of the SDK workaround) they still express displeasure towards Capture One and sometimes even ask about alternative tethering software.

Thought I would share my experience with this issue.

Weber

Re: New Canon SDK in 6.4.5

PostPosted: Fri Jan 18, 2013 10:58 am
by Drew
Canon has solved the issue and we've implemented a fix in Capture One 7.0.2.
We've also been big proponents of the FREE workaround should someone not want to pay for the upgraded software we've built.

All in all, I think we've done quite a bit to ensure there is a solution for Canon/Apples conflict which every user can take advantage of.

Re: New Canon SDK in 6.4.5

PostPosted: Fri Jan 18, 2013 7:16 pm
by GoranLjubuncic
Implementing a buggy SDK without properly testing it IS a bug. Bottom line is that 6.4.4 is "defective" on 10.8. Implementing a new SDK and releasing a 6.4.5 is not a big problem for Phase One and would go a long way but obviously from your comments it's clear that Phase One doesn't intend to support COP 6 anymore. That's not how you compete with Adobe and Apple.

Re: New Canon SDK in 6.4.5

PostPosted: Sat Jan 19, 2013 11:31 am
by Drew
GoranLjubuncic wrote:Implementing a buggy SDK without properly testing it IS a bug...

But the SDK is NOT "buggy", it is simply limited in compatibility with certain Apple OS's. These limitations are outlined in the release notes for the software and our testing provided available information for workarounds and "Best Case" usage.

Re: New Canon SDK in 6.4.5

PostPosted: Thu Mar 07, 2013 1:21 pm
by Drew

Re: New Canon SDK in 6.4.5

PostPosted: Tue Mar 12, 2013 4:53 pm
by holger666
still don ´t work (EOS 1Ds M2) with 6.4.5, Mac OS 10.7.5. not with Firewire or USB!!!

Re: New Canon SDK in 6.4.5

PostPosted: Tue Mar 12, 2013 8:13 pm
by Paul_Steunebrink
holger666 wrote:still don ´t work (EOS 1Ds M2) with 6.4.5, Mac OS 10.7.5. not with Firewire or USB!!!

Was not supposed to work as the newer SDK from Canon is not supporting the 1Ds mk II.
Note that tethering with this camera is only supported through firewire.

Last version officially supporting this camera is CO Pro 5.2.1, however initial versions of CO Pro 6 tether fine too. Try 6.4.2 and if that does not work revert to 6.1.1. Note that these versions might not work properly with OS X 10.7.5.

See also this post:
viewtopic.php?p=66025#p66025

Tip:
Always look at the release notes for each release for supported cameras.

Re: New Canon SDK in 6.4.5

PostPosted: Mon Apr 08, 2013 3:28 pm
by R_Weber



Hi Drew,
We upgraded to 7 on our rental machines a few months ago, but I still get requests from users working with the latest Apple OSes who want to tether their new 5D III's who own 6. Now I have an easy answer for them!

Thanks for the hard work,

Weber

Re: New Canon SDK in 6.4.5

PostPosted: Mon Apr 08, 2013 3:31 pm
by R_Weber
Also, I thought I would note that in the release notes for 6.4.5 Canon tethering support is now listed under "Bug Fixes" :wink: